PHP4 not available in Feisty

I’ve started to see this topic come up again and again lately. PHP4 is *not* in Feisty Fawn’s repositories at all and has been completely replaces by PHP5. It’s been discussed a few times in the forums, and I suspect it will continue to pop up occasionally. You can always look in the mailing lists to see this topic discussed.
PHP4 hasn’t been supported for the last 3 releases (but it was packaged and in the repositories), and it seems most of the major distributions have also stopped providing it. PHP4 has many well-known security issues, since PHP5 has been in the wild for over 4 years, and most big hosting companies are moving towards it.

Personally, I’m not sure if I agree with removing it completely (and without making a more public announcement), I still use PHP4 in all my production servers (Ubuntu Dapper’s and Fedora’s, and my company develops for PHP4, so this is a bit of a complication.

I guess it’s time to move on.

11 thoughts on “PHP4 not available in Feisty

  1. I don’t think most hosts have moved to PHP5 yet. I’ve heard all sorts of stats stating anywhere between 50/50 split to 80% still on php4. It’s hard to know for sure but the the truth is that v4 user base is still too large to ignore.

    The big deal was recently RHEL5 shipped with PHP5. However I agree with you, the package should not have been entirely removed.

  2. I discovered this earlier today. I’m torn because I really want to upgrade my development machine to feisty, but my company is using php4. Does anyone know if there is a good way to install php4 on feisty?

  3. Yes. It was a big surprise for me too, when I’ve upgraded my notebook till Feisty Fawn last weekend. But it isn’t not last surprise! PHP version 4.4.6 from http://www.php.net cannot be compiled on Ubuntu 7.04.
    After all troubles I’ve installed PHP 4.4.7, Apache 2.0.59 and Mysql-5.0.37. They work quite fine.

  4. I agree. Move on. Remove php5 from the repos as well and move to Rails.

  5. You could try a self-contained version instead. These are great for development and work on different platforms too.

    I think that XAMPP has a Linux version.

    Regards, J.

  6. As Rich said, the end of all upstream support for PHP4 appears to be Dec 31st 2007, while Feisty is being supported through 2008. That’d be a year of the package’s life that it would be unsupported by anyone except possibly ubuntu.

    The upgrade path from php4 to php5 has some small compatibility issues, but a majority of the code you run into should work without trouble.

  7. Thanks for the warning.

    I personally don’t have a choice about PHP4 since my company uses PHP4 on Solaris and I use my machine for development. Like it or not, not all developers are able to influence company policy.

    @Sergey, thanks for pointing out that PHP 4.4.7 compiles. I need to compile PHP anyway to support Oracle so this isn’t that big a problem, but it is still a disappointment since the lack of support means that Feisty 1 might not compile PHP 4.4.7 and I’ll have no choice but to stick with it until my company changes.

  8. Pingback: kbglob - tecnologia para geeks, no para tu mamá » PHP4 no más en Ubuntu 7.04 Feisty Fawn

  9. One can agree or disagree on including php4.

    The automatic updater should:

    1) keep into account the choice that has been made (stick with php4 or upgrade to php5) 2) be stable when released

    we upgraded development machines, and the updater caused a total mess, half installing php5, breaking dependencies, forgetting to install some of the modules and of the components.

    If in future you decide again to exclude versions of packages, please be sure the updater keeps that into account before releasing.

    Best,

  10. The key phrase here is “most big hosting companies are moving towards it”. Ask them, and they’ll tell you “yes, we plan to start a PHP5 beta program, any year now!”. The problem is that they do what their customers need, and they know the PHP maintainers are far too amateurish to produce a reliable upgrade path. Look at the mess when they randomly changed how reference passing worked in a minor point release of PHP4. If you were running a real commercial webhosting business, would you risk breaking every one of your customers’ websites by upgrading to an incompatible version of the language your customers are using? Especially when most PHP programmers are self-taught and couldn’t debug their own code to save themselves?

    So no, PHP4 is not dead, and PHP5 is the biggest piece of vapourware since Duke Nukem Forever. This decision makes me bloody angry.

Leave a Reply

Your email address will not be published. Required fields are marked *